Ask Your Question
0

Pastèque sur OVH mutualisé

asked 2017-07-07 13:51:12 +0200

LeChi gravatar image

updated 2017-07-08 10:16:46 +0200

Bonjour à tous,

je tente moi aussi d'installer Pasteque sur un hébergement mutualisé d'OVH.

L'installation ne démarre pas. Message

Error connecting to database, check your creditentials

Une première question, Pasteque accepte-t-il une base MySQL ?

Cordialement,

chi

edit retag flag offensive close merge delete

Comments

Je reprends cet essai. Précisons que j’en suis à mon 10e site chez OVH (pour moi et des amis) et que j’ai installé agora-project, piwigo, owncloud, wordpress. J’ai donc quelques notions d’installation.

LeChi gravatar imageLeChi ( 2017-08-18 13:18:54 +0200 )edit

Ce qui m’étonne ici, c’est que dans la page de démarrage d’installation, on ne demande pas le nom du serveur. Voici les champs demandés : pour la base de données (Database user + Database password + Database name), pour pasteque (Username + Password) et un debug level (qu’est-ce ?).

LeChi gravatar imageLeChi ( 2017-08-18 13:23:42 +0200 )edit

3 answers

Sort by » oldest newest most voted
1

answered 2017-07-07 18:05:30 +0200

Cyrille BORNE gravatar image

aucun problème pour une installation chez o2switch, il s'agit certainement d'une erreur dans les informations communiquées.

edit flag offensive delete link more

Comments

1

Je confirme. Le message « check your credentials » dit qu’il y a une erreur. Avec l’installeur, il va te falloir afficher les options avancées pour définir l’adresse du serveur de base de données et vérifier l’identifiant, mot de passe et le nom de base de données.

philippe gravatar imagephilippe ( 2017-07-08 10:15:08 +0200 )edit
1

answered 2017-08-28 15:13:12 +0200

Postech_user gravatar image

updated 2017-08-30 19:58:08 +0200

L'installation de l'application sur un mutualisé OVH vient d'être effectuée chez moi. J'ai été confronté à 2 petits "bugs" de la version actuelle.

1) Tout d'abord, il n'y a pas de "dbhost" dans le formulaire d'installation. Cela entraine que dans le fichier "\inc\installer.php" la fonction "sanitizendefault()" met toujours "localhost" par défaut, ce qui ne fonctionne pas chez OVH.

Solution temporaire utilisée: ajouter dans le fichier "\templates\pasteque-bootstrap\install.php" un champ "dbhost" pour pouvoir le remplir. (C'est sans doute ce que voulait montrer Osel dans sa réponse?)

2) A ce stade, j'ai eu un message comme quoi la DB n'existait pas... puis qu'elle ne pouvait pas être créée car elle existait déjà.

Solution temporaire utilisée: dans le fichier "\inc\installer.php", on dirait que le test pour tester l'existence de la DB ne fonctionne pas correctement chez OVH? J'ai simplement mis la variable "$dbexists" à true, car j'étais sûr que la DB existait... et c'est passé, les tables ont bien été créées. Je n'ai pas pris le temps de tester pourquoi le test ne fonctionnait pas, ni d'étudier la structure des DB chez OVH.

A noter que je n'ai pas encore vraiment utilisé l'application pour tester si tout va bien sur un mutualisé OVH. (J'attends d'abord de récupérer les données d'un autre serveur avant de les injecter.)

En tout cas, c'est cool, je suis content que ça semble fonctionner, n'ayant pas de VPS à disposition et n'ayant pas particulièrement envie de changer d'hébergeur.


Pour l'historique, la première réaction:

Bonjour,

J'essaie également d'installer Pasteque server sur un mutualisé ovh. J'ai suivi le tutoriel indiqué ici: https://ask.pasteque.org/question/138/tutoriel-dinstallation-sur-mutualise/ Et comme pour d'autres apparemment, ça ne fonctionne pas: "check your credentials".

OVH fourni comme informations: Nom d'utilisateur : xxx, Nom de la base : xxx, Adresse du serveur : xxx.mysql.db Même si ça ne semble pas être une adresse complète, cette adresse OVH n'est en effet pas demandée. Est-ce censé fonctionner avec "localhost"?

J'ai donc tenté de faire l'installation "à la main" en suivant cette page du wiki: https://fr.wikibooks.org/wiki/LogicielPast%C3%A8que/Serveur/Installation#Debugmode

Je ne suis pas vraiment sûr de bien avoir réalisé les bonnes étapes... J'ai changé les "config-sample.php" et "config.php"... J'ai tenté d'ajouter le bon répertoire pour placer des fichiers xxxdb.ini et xxxid.ini, en essayant de bien créer ceux-ci également. Je n'étais pas convaincu d'avoir bien compris/configuré et en effet ça ne fonctionne pas: l'écran "Pastèque Login" s'affiche bien, mais pas moyen d'interagir.

Bref, c'est dommage... et un peu frustrant. :) Sur OVH l'application semble bien en place, la DB est prête à être remplie, mais je n'arrive pas à effectuer l'installation ... (more)

edit flag offensive delete link more
0

answered 2017-07-11 22:46:18 +0200

Osel gravatar image

Bonjour,

Même problème pour moi chez Infomaniak avec ce message d'erreur :

Error connecting to database, check your creditentials

Il manque la case : l’adresse du serveur de base de données

<body>link awaiting moderation</body>

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-07 13:51:12 +0200

Seen: 200 times

Last updated: Aug 30