Ask Your Question
0

Android: L'application "Pasteque" s'est arrêtée

asked 2017-08-09 12:16:41 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Bonjour,

Je suis nouveau avec vous. J'ai installé la version serveur j'ai fait mes premiers testes avec succès. La version Desktop marche très bien mais celle du sur android ne marche pas. Lorsque je clique sur Connexion et mise a jour elle se ferme et se relance en affichant: L'application "Pasteque" s'est arrêtée.

PS: J'utilise bien la version 7 pour le Serveur, Desktop et Android. URL Serveur: http://limphost.com/past admin login: admin admin mdp: admin Sans SSL!

Merci.

edit retag flag offensive close merge delete

Comments

C'est très probablement à cause du nom de la machine coté Android (et peut être du coup la bdd qui ne s'est pas correctement initialisée coté serveur). https://framagit.org/pasteque/pasteque-android/issues/24

Cédric gravatar imageCédric ( 2017-09-14 11:35:49 +0200 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2017-08-09 13:52:04 +0200

La version de Desktop est-elle bien la 7 ?

Sinon, dans les paramètres, dans les options avancées, que dit le crash log ?

edit flag offensive delete link more
0

answered 2017-08-10 11:54:40 +0200

subsurolod gravatar image

Bonjour, Oui j'ai la version 7 pour les trois.

Sur le log j'ai ce message:

Pasteque has crashed, here is the log class.java.lang.NullPointerException:null fr.pasteque.client.sync.SyncUpdate$1:run (line 227) caused by: null

Pour continuer mes testes j'ai mis une autre instance (past2). Et jusqu'à maintenant tout marche bien (Appart le symbole du Euro sur la version android même si j'ai changé le symbole sur l'administration Web).

Merci.

edit flag offensive delete link more

Comments

OK. Que disent les logs côté serveur ? Le problème me semble intéressant :)

philippe gravatar imagephilippe ( 2017-08-11 08:36:57 +0200 )edit

Bonjour, Sur le serveur j'ai ce log: http://limphost.com/past/error_log_back170810.txt PS: Les commentaires sont limités, je l'ai mis dans un fichiers texte. Sinon pour le symbole de la devise sur la version Mobile, il prend pas la valeur des paramètres? Merci.

subsurolod gravatar imagesubsurolod ( 2017-08-11 12:59:38 +0200 )edit

La création de la base de données semble avoir échoué vu les logs. C’est ce qui explique que sur un second serveur, ça marche mieux

philippe gravatar imagephilippe ( 2017-08-11 21:10:25 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-09 12:16:41 +0200

Seen: 18 times

Last updated: Aug 10